Met à jour votre application et ses dépendances. Voir https://update.angular.io/

ng update [options]

La description

Effectuez une mise à jour de base de la version stable actuelle du framework principal et de la CLI en exécutant la commande suivante.

ng update @angular/cli @angular/core

Pour mettre à jour vers la prochaine version bêta ou pré-version, utilisez le --next option.

Pour passer d’une version majeure à une autre, utilisez le format

ng update @angular/[email protected]^<major_version> @angular/[email protected]^<major_version>

Nous vous recommandons de toujours mettre à jour vers la dernière version du correctif, car elle contient des correctifs que nous avons publiés depuis la version majeure initiale. Par exemple, utilisez la commande suivante pour prendre la dernière version 10.xx et utilisez-la pour mettre à jour.

ng update @angular/[email protected]^10 @angular/[email protected]^10

Pour des informations détaillées et des conseils sur la mise à jour de votre application, consultez la Guide de mise à jour angulaire.

Options

Option La description Type de valeur Valeur par défaut
--all

Obsolète

S’il faut mettre à jour tous les packages dans package.json.

boolean false
--allow-dirty

S’il faut autoriser la mise à jour lorsque le référentiel contient des fichiers modifiés ou non suivis.

boolean
--create-commits

Créez des commits de contrôle de source pour les mises à jour et les migrations.

Alias : -C

boolean false
--force

Si false, une erreur s’affichera si les packages installés sont incompatibles avec la mise à jour.

boolean false
--from

Version à partir de laquelle migrer. Uniquement disponible avec un seul package en cours de mise à jour et uniquement lors de la migration.

string
--help

Affiche un message d’aide pour cette commande dans la console.

true|false|json|JSON false
--migrate-only

Effectuez uniquement une migration, ne mettez pas à jour la version installée.

boolean
--next

Utilisez la version préliminaire, y compris la bêta et les RC.

boolean false
--packages

Les noms des packages à mettre à jour.

array
--to

Version jusqu’à laquelle appliquer les migrations. Uniquement disponible avec un seul package en cours de mise à jour, et uniquement sur les migrations uniquement. Nécessite d’être spécifié. Par défaut la version installée détectée.

string
--verbose

Afficher des détails supplémentaires sur les opérations internes pendant l’exécution.

boolean false